Login    Register
  • Author
    Message

Outdoor temperature unstable

Postby tommylewis » Fri Oct 20, 2017 4:32 pm

On my flight yesterday the outside temperature displayed on the HX on the engine page bounced all over. The temperature on the EIS is rock solid but the temperature displayed on the engine page bounces all over. It was 64 degrees yesterday and went from -25 to 110 deg. It did display 64 deg but kept bouncing around to other temps. The problem is that effects the percent power displayed, it bounces all over also. Anyone have any ideas what causes this?
tommylewis
 
Posts: 19
Joined: Mon Mar 11, 2013 11:33 pm

Re: Outdoor temperature unstable

Postby Bobturner » Fri Oct 20, 2017 8:05 pm

Most likely a poor connection somewhere. Could also be a poor connection internal to the probe. Temporarily replace the probe with a resistor of about the same value as the probe, go fly. If the indications are now steady, the probe or its connections have a problem. If the readings still bounce around, look at other connectors.
Bobturner
 
Posts: 369
Joined: Mon Mar 11, 2013 6:34 pm

Re: Outdoor temperature unstable

Postby GRT_Jeff » Fri Oct 20, 2017 10:42 pm

If the OAT on the EIS is solid, and your other EIS data is solid, the EFIS may be picking up something on another OAT input like the AHRS. Try going to SET MENU, General Setup, and setting Outside Air Temperature Source to EIS. If there's no OAT sensor connected to the AHRS it shouldn't be reading anything there though (the AHRS should report -40 or below).
GRT_Jeff
 
Posts: 496
Joined: Tue Dec 11, 2012 12:11 am

Re: Outdoor temperature unstable

Postby tommylewis » Sat Oct 21, 2017 2:49 pm

Yes, the temp and everything else on the EIS is solid so I ruled out bad connections. I will be flying home on Monday so will go check the setup. Thanks for the hint Jeff.
tommylewis
 
Posts: 19
Joined: Mon Mar 11, 2013 11:33 pm

Re: Outdoor temperature unstable

Postby tommylewis » Tue Oct 24, 2017 1:36 am

Jeff was right. I checked all three HX units on today's flight and found all three setup with OAT as auto. Changing the setting to EIS resolved the issue and the OAT worked great. This RV7a is 10 years old with WS units installed originally and then upgraded to HX units 6 years ago. The auto setting had worked until recently.
tommylewis
 
Posts: 19
Joined: Mon Mar 11, 2013 11:33 pm

Re: Outdoor temperature unstable

Postby GRT_Jeff » Tue Oct 24, 2017 4:17 am

You may want to check the OAT pins (pin 10) on each AHRS. If they aren't used, they would have to see a connection to ground to start jumping around. If it's just the OAT then that's not a big deal as you're not using that input. If there's a problem with the analog sensor processing inside the AHRS it could affect your magnetometer, airspeed, and altimeter data.
GRT_Jeff
 
Posts: 496
Joined: Tue Dec 11, 2012 12:11 am

Return to Horizon HX

Who is online

Users browsing this forum: No registered users and 1 guest

cron