Login    Register
  • Author
    Message

No guidance to ILS

Postby 330drvr » Wed Nov 20, 2019 3:59 pm

I am having problems with ILS approach. On two separate flights, the guidance given to the flight director/autopilot is incorrect to maintain the Localizer. Pitch is fine. Upper left shows LOC and ENAV in white as it should. Guidance keeps giving a right correction when I am already right of the localizer. Signal strength is fine. Raw data loc and g/s are fine. ILS identifies just fine. RNAV approaches are fine.

Any ideas?

Dual HX plus mini. Garmin GNS 480. Trutrak VGSV digiflight II
330drvr
 
Posts: 58
Joined: Sun Mar 24, 2013 5:30 pm

Re: No guidance to ILS

Postby GRT_Jeff » Thu Nov 21, 2019 3:01 am

It sounds like the course select is wrong. Make sure you tune the correct localizer frequency in the radio before you ARM the EFIS. Then check the course indicators and fields after you ARM. This is the double triangle in the compass/heading tape and the right knob (CRS) on the map pages. The EFIS uses the course setting to point in the general direction of the localizer course and then makes corrections using the deviation data. When you ARM LOC or ILS, the EFIS searches its navigation database for the tuned localizer frequency and tries to set the course for you. You will get a flashing message on the screen with the result. If something goes wrong with that, you have to set the localizer course using the course knob (right knob) on the map.
GRT_Jeff
 
Posts: 579
Joined: Tue Dec 11, 2012 12:11 am

Re: No guidance to ILS

Postby 330drvr » Thu Nov 21, 2019 1:10 pm

Thanks for the post Jeff. I will check it out and reply.
330drvr
 
Posts: 58
Joined: Sun Mar 24, 2013 5:30 pm

Re: No guidance to ILS

Postby 330drvr » Fri Nov 22, 2019 2:31 pm

Jeff:
I tested this in the hangar yesterday using sim mode on the GPS. The localizer front course for KBKV did NOT load automatically and I had not caught that previously in the air. I tried again at KPIE and it did load automatically as I am use to. So there must be something in the database for KBKV that doesn't pass along the front course information to the EFIS. I will keep an eye out in the future for this possibility. Thanks for your help.
330drvr
 
Posts: 58
Joined: Sun Mar 24, 2013 5:30 pm

Re: No guidance to ILS

Postby GRT_Jeff » Sat Nov 23, 2019 4:09 am

It looks like one of our FAA database sources has the wrong localizer frequency for I-OSV, so the EFIS is not able to match them. I have notified them.
GRT_Jeff
 
Posts: 579
Joined: Tue Dec 11, 2012 12:11 am

Re: No guidance to ILS

Postby 330drvr » Sat Nov 23, 2019 3:23 pm

I did test this in the air today. Front course did not load at KBKV but accepted the course manually and flew perfectly via flight director and autopilot. At KPIE the front course loaded automatically and flew well also. KBKV LOC frequency had changed in July. That appears to be causing the problem. Again thanks for your technical analysis.
330drvr
 
Posts: 58
Joined: Sun Mar 24, 2013 5:30 pm

Return to Horizon HX

Who is online

Users browsing this forum: No registered users and 1 guest

cron