Login    Register
  • Author
    Message

EGT display on EFIS - 1 of 6 cylinders displays differently

Postby BillinDurham » Sun Dec 09, 2018 6:32 pm

In the beginning, all 6 cylinder’s EGT bar graph, as sensed by the EIS and displayed on an HX (and now on an HXr as well), looked and functioned normally.

At some point cylinder 6 displayed no bar graph value when relatively cold while the other 5 cylinders’ bars displayed nominal values. Once reaching the normal range of values, the 6 bar began displaying normally.

I probably caused this my inadvertently making a settings change in the EFIS or even perhaps the out of sight EIS. It’s as if the 6 bar is simply setup differently but I can’t make any sense of where such setup change can be made.

I’ve also replaced several EGT probes over the years, which could have had an effect but i have difficulty seeing how that might occur.

Any advice on where to look or how to troubleshoot appreciated!
Bill Watson
8NC8 Durham, NC
RV10 HX, G430w, NavWorx, EIS
User avatar
BillinDurham
 
Posts: 23
Joined: Sat Mar 16, 2013 10:53 pm

Re: EGT display on EFIS - 1 of 6 cylinders displays differen

Postby GRT_Jeff » Wed Dec 12, 2018 7:34 am

There is no setting that can cause one of the EGT inputs to behave unlike the others. This has to be something going on in hardware. It could be a weak connection or failing probe. The EGT/CHT Basic Troubleshooting section in the EIS Troubleshooting Guide may help for checking the probes and wiring.
GRT_Jeff
 
Posts: 563
Joined: Tue Dec 11, 2012 12:11 am

Re: EGT display on EFIS - 1 of 6 cylinders displays differen

Postby BillinDurham » Tue Dec 25, 2018 2:34 pm

I have yet to go through the troubleshooting guide. After reading it, I will probably end up swapping in a new probe which I suspect will fix it.

However, I’ve attached 2 photos:

1) The first shows a cruising situation with the EGT set to display changes relative to a point in time. Cylinder 6 ‘1F’ appears to work normally.

2) The second shows the same cruising situation with EGT set to display the actual temperature. Here one can see that
Cylinder 6 displays a temp ‘220F’ that is impossibly low.

Any comments welcomed.
2388F62C-76C2-42F8-B24C-0DF39F8BE280.jpeg
2388F62C-76C2-42F8-B24C-0DF39F8BE280.jpeg (778.65 KiB) Viewed 766 times
4A42A300-A258-4875-A3DB-7DC18E622FEA.jpeg
4A42A300-A258-4875-A3DB-7DC18E622FEA.jpeg (842.04 KiB) Viewed 766 times
Bill Watson
8NC8 Durham, NC
RV10 HX, G430w, NavWorx, EIS
User avatar
BillinDurham
 
Posts: 23
Joined: Sat Mar 16, 2013 10:53 pm

Re: EGT display on EFIS - 1 of 6 cylinders displays differen

Postby Bobturner » Wed Dec 26, 2018 5:42 am

The normalize mode just shows how the CHT has changed since the mode was first selected. Evidently #6 was at 219, it’s now at 220, so it’s changed one degree. Most likely a new probe is needed; they live a hard life.
Bobturner
 
Posts: 392
Joined: Mon Mar 11, 2013 6:34 pm

Return to EIS Programming

Who is online

Users browsing this forum: No registered users and 2 guests

cron